PDA

View Full Version : Help! How can I make Custom Content and AnyGameStarter play nicely?


EmeraldFalcon
19th Sep 2015, 5:21 PM
This was my best guess as to where a thread like this should go, so if I am wrong, please, by all means, move it to where it should be.

I am working on building a new, custom tropical vacation destination. Since that's a lot of work in the first place, I want my finished project to be shareable, so I'm building the whole thing in AGS with only base game and Bon Voyage installed.

I've chosen three collections of custom content that I don't think I can do without--Huge Lunatic's Tropix build set add-ons, Havelock's converted Castaway Stories Trees and Shrubs (http://www.moreawesomethanyou.com/smf/index.php/topic,12053.0.html), and the harvestable trees that Pescado converted from Castaway Stories (only because Havelock's set uses a texture from those trees).

Now, I've put all three sets into the Downloads folder for my AnyGame 3, which is the one I've set up to be Bon Voyage and Base Game. HL's set and Pescado's set show up in game just fine, but Havelock's set does not.

Here are the things I've tried already:

1. Manually looking through every section of the catalog (this brought the revelation that Pescado's trees are in the "all" sort for plants, but not in any specific category :rolleyes: ) but did not turn up Havelock's stuff.
2. Opening up a few of the plants in SimPE to see where they are sorted in the catalog. They ARE sorted into categories, but they do not show up in those categories ingame.
3. Checking Havelock's original post for an EP requirement--the only thing he mentions is that one of the files needs BV, so I assume that there is no other EP requirement. Pescado's trees have two versions, one for Seasons and one without, but like I said, his are showing up just fine. Even if I have the wrong file for the texture that Havelock borrowed, that was only one type of tree, so the rest should show up.
4. Moving the files from "Downloads" to "Saved Sims" to see if they would load from there--they did not.
5. Enabling and disabling the custom content dialog on game startup--the package files ARE listed in the custom content dialog box, but again, they don't show up in game.
6. Enabling and disabling the "allow custom content" option ingame--although like I said, the other custom content pieces are showing up alright.
7. Checking the catalog on both residential and community lots (nothing).
8. Putting the files in my regular game (not AGS)--they show up just fine. Even the files with textures missing from Pescado's set are still in my catalog with a dry state, as Havelock's documentation says.

So it is at this point that I rather feel I've tried everything I can think of. Based on the fact that the files show up in my regular game, I am given to think the problem is with AGS, and since that program is unsupported and I'm fairly new to it anyway, I thought I would see if any of you kind folks who have more experience with it than I do might know another trick or two.

Thanks for reading.

EmeraldFalcon
23rd Oct 2015, 2:21 AM
For posterity--

I resolved the issue by adding Seasons to the AGS configuration. Not what I wanted, but I think it'll be worth it in the long run. There's a lot of things that come with Seasons that I can spin into vacation.