Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 13 (Who?), Viewed: 931 times.
Link Ninja
Original Poster
#1 Old 22nd Jan 2018 at 7:59 AM Last edited by Charmful : 5th Sep 2018 at 5:49 PM.

This user has the following games installed:

Sims 2, University, Nightlife, Open for Business, Pets, Seasons, Bon Voyage, Free Time, Apartment Life
Default [Occurring again] Sim gone when moved into new lot and is build mode only
Agh, okay so this problem I cannot figure out. A sim graduated from Uni and he can't be moved into a lot by himself. Meaning, once I move him into the lot, and it loads - it shows the taxi and as soon as the taxi zooms off, the guy is nowhere and the lot is in build mode, no live mode available because the sim is nowhere.

Some facts:

1. The apartment lots I have moved him to have had sims there before just fine. I have tried moving him into two apartment lots and a blank residentail lot but they all go straight into build mode and the sim is gone.

2. I had him move in with his parents via the teleportation cat and he seemed fine but as soon as he left to 'find his own place' and moved in the same thing happened.

3. I tried moving a different single sim into one of the same apartment complexes to see if the problem affected more than just my first sim and he showed up like normal so this affects just this one sim and I don't know why. Is there any tips or tricks anyone could give me to look for in SimPE so he is able to move in to a new apartment or lot by himself?

Or anyone have this happen before and able to fix it?

**Update** Fact 4. I was able to move him from the dorm to a graduation party lot just fine. It was only after he graduated and I was moving him from the normal sim bin to a downtown, the issue came up.

Uh oh! My social bar is low - that's why I posted today.

Advertisement
Mad Poster
#2 Old 22nd Jan 2018 at 8:35 AM
I would look very carefully at the cc on the sim myself. (I say that due to the problem I had a while back with 3 male sims not being able to eat in my game. Different households, huge hood, only those 3. Took me some time to realise they had the same hairstyle. Turns out I had both the original and a fixed mesh for that hairstyle in my downloads folder. Rmoved the original mesh and they all ate like kings ).

Since you can move other sims in and out, I don't think the problem is with the lots.
Link Ninja
Original Poster
#3 Old 22nd Jan 2018 at 8:49 AM
The first time I moved him in he was in maxis clothing because he had just aged to adult after graduation. However, he was born with custom eyes and I think he kept his custom hair from Uni. I can try changing his hair but he was the only guy moving in to an otherwise empty apartment with no other occupants. Did you find that out just by testing in game or did you find that out in Sim PE?

Uh oh! My social bar is low - that's why I posted today.

Mad Poster
#4 Old 22nd Jan 2018 at 10:02 AM
Actually, when I realised that the sims had the same hairstyle (It took me some time, to be honest; big hood, different colours hair) - I just went and looked at the hair in my downloads folder. (And, to be fair,there was a readme doc from the creator, as well as the 2 meshes side by side, so all my own fault).
Link Ninja
Original Poster
#5 Old 22nd Jan 2018 at 6:54 PM Last edited by Charmful : 25th Jan 2018 at 8:25 PM.
Here's some things I have planned to test:

1. Move him back in with his parents via teleportation cat, and then change his hair to maxis. See if that affected him. This didn't work when I gave him maxis hair.

2. If not, have him move in with another already occupied apartment lot and see if he ruins their life by making it go into build mode and both sims are missing or see if the other sim's agency overpowers original sim guy's issue and they both are playable like they should be. In that case I will just have to use a sim buddy for him to move around the rest of his life. The game crashed when I tried moving him with the sim already on the lot

3. I dread if step 2 doesn't work, but then the next step would be removing the new job mod I downloaded from Lamare (the sim doesn't have a job through it, but it's the most recent mod I had put in my game before this issue presented itself) Ruling out the mod as culprit because I could move a sim in with the same circumstances without issue.

Things I did:
Tried combining the sim with the normal one into the apartment lot the normal one moved into fine. This newly graduated problem sim crashed the game when trying to combine families and load.

Gave him vanilla hair, still crashed.

I moved out a different graduated-from-uni sim into the neighborhood with no problems so I'm ruling out Lamare's mod having to do with the weirdness for the original sim with issue.

I HAVE NO IDEA WHY HE IS LIKE THIS. MAYBE IT'S JUST CORRUPTION.

So I am going to try my back up from last week before he got weird to see if it makes a difference.

Uh oh! My social bar is low - that's why I posted today.

Link Ninja
Original Poster
#6 Old 26th Jan 2018 at 2:40 AM
Things I did:
1.Restored hood from last week's back up after an ordeal of trying to get my hood to show up
2. Cheated to get him graduated to test if he can move out to the big bad world without going into build mode
3. Had him peace out of SSU
4. Moved him into an apartment
5. He shows up, and it doesn't go straight to build mode.

So, I have NO idea what caused him to bork out in the first place by my theory is that it had something to do with a texture memory glitch (where everything turns flashing magenta) because the first apartment I move dhim into was full of flashing pink. I quit without saving so he was still on the lot when I loaded the game and moved him out. I dunno, something changed him and he was forever borked.

TL;DR: ALWAYS BACK UP YOUR HOODS because it might be the onlyt hing you can do to fix an issue.

Uh oh! My social bar is low - that's why I posted today.

Link Ninja
Original Poster
#7 Old 16th Aug 2018 at 5:34 PM
Eight months later and this problem has shown up again - I don't want to open a new thread because it's the same issue minus a few factors.

1. Different sim I haven't played in a few months but the last time I played he was fine.
2. I hadn't moved him into a new place to find the issue, he was in the apartment he had been in and when I went to play I found it stuck in build mode.
3. I moved him out of the apartment he lived in, to combine him with a different sim family in a different apartment where he seemed fine and nothing crashed, unlike the first sim I had this happen to above when I tried combining families and it crashed.

I would like him to be playable on his own again without being forced into buy/build mode with no trace of the sim. I don't know what to look for in SimPE to see if he is borked or how to fix it. So this is my plan in order of operation if no one can advise why he is the way he is.

1. Back up.
2. Remove CC and see if something there is freaking him out (though to be totally honest I haven't downloaded that much recently)
3. If step 2 doesn't resolve, try replacing the sim character file with the previous back up character file (like I asked about this morning in stupid/random questions thread) to see if he will be fixed
4. If step 3 doesn't resolve, then try restoring whole game from previous back up (the one before step 1 back up) to see if that back up had him normal and playable.
5. If step 4 doesn't resolve and he's still borked, since he didn't crash when I combined him with a family, he will have to have like...a buddy sim or probation officer with him at all times so he can stay playable.

Uh oh! My social bar is low - that's why I posted today.

Link Ninja
Original Poster
#8 Old 5th Sep 2018 at 7:43 AM
Hey sorry to bump this but I found some info and I'm trying to make sense of it.

So I found two of my otherwise playable sims (the first guy and second guy I report in this thread) who are found in the default family in the teleporter family lists. They are both in family instance 0x0058 when I look at their files in SimPE (nothing really looks off in their files either, they have complete character data etc).

So I tried adding one of these guys, while in game to a household. However whenever I would select the playable sim in the household to move in the guy I would get a Undefined Transition error as such:



After searching around I found various reasons for this but none with the same situation. I tried manually changing the guy's family instance in SimPE after I quit the game (Gabriella, who is mentioned in the error code was the sim who I was trying to get him to move in with) but when I went to save my change SimPE threw an out of memory exception.

I'm just wondering what's up with these sim files so they can't be moved in via regular in-game mods like the blender or teleportation hacked object which I have used before to move sims in, and it's fishy SimPE throws an memory error when I try to manually edit the family instance event though all the character data looks fine.

Uh oh! My social bar is low - that's why I posted today.

Link Ninja
Original Poster
#9 Old 10th Dec 2018 at 9:37 AM
Ok so like...after months, I finally think I know what happened. It occurred to me that the three sims affected all were in a boys dorm in college. One day, back in Dec 2017 the dorm lot just refused to load, it would crash every time I tried to go into it so I just moved them out and into another dorm where it did load and they played out their graduations, and then moved to the city. Every single one of them SEEMED FINE for a little while, were playable, but eventually all of them suffered from the same problem of where I would go into their lot and it would be build mode, sim gone. I think their files somehow, over time, got corrupted from that crashed lot. I was alarmed to go back into the uni hood and find that the game still recognized them as living in that dorm, even more shocked when I loaded it and the guys were THERE! Though they were adults...bizarro. So they aren't completely fixed but I did find out if they move in with a normal sim, I can still play them. Just...not by themselves. This is a very specific weird, problem but I'm gonna go ahead and say I've done all I could to help them rehabilitate their weird corrupted file lives.

Uh oh! My social bar is low - that's why I posted today.

Field Researcher
#10 Old 10th Dec 2018 at 11:50 AM
This might sound like a stupid suggestion, but have you tried using the batbox to fix bad apartment residencies?
Link Ninja
Original Poster
#11 Old Yesterday at 2:22 AM
@Modder - I'll reply with maybe a stupider question (not that yours is stupid at all, I just feel dumb cause I never tried it) but how can I if I can't select the batbox because there's no controllable sim on the apartment lot (it goes straight to build mode when loaded)? Or will doing on any lot fix all bad residencies globally? Sorry, I don't use batbox to it's full capacity on the account I don't know a lot of the options do exactly.

Uh oh! My social bar is low - that's why I posted today.

Field Researcher
#12 Old Yesterday at 7:42 AM
@Charmful I believe if you use the option on any lot it will fix bad residencies globally. At least that's my experience with it. I may be wrong
Theorist
#13 Old Yesterday at 11:59 AM
You're not wrong. That's been my experience as well. Pick another house that works and use the option there to fix the whole neighborhood.
Instructor
#14 Old Yesterday at 1:39 PM
I think there is something wrong with the sim, according to your error log.
Node: 4 of Interaction - Family - Add to Family on Sim Blender is a Generic Sims Call. The only way to get the Undefined Transition error there is if it returns false which can only happen if there's something wrong with one of the two parameters.

The first parameter, Temp 0 defines the family to add the sim to, it has just been set to zero which means use the current family so provided the current family is Gabriella's then it can't be wrong.

That only leaves the other parameter which is the neighbour ID to add to the family, the current object id has just been set to that neighbour id which is decimal 935 so we know he does have a real neighbour ID. The only thing left is if the sim with that neighbour ID is not a legitimate sim, perhaps he's become unlinked or has some other incorrect/unusable data.

Check the Object Data (OBJD) in his character file, that the Object type is 'Person' 0x0002, if he's type 'Unknown' 0x0011 then he is unlinked, check also that he does have an Age Data in his character file if the game finds two of the same sim it'll often remove that from one of them.
Back to top