Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 21 (Who?), Viewed: 36343 times.
Original Poster
#1 Old 15th May 2013 at 8:30 PM Last edited by grimreefer24601 : 19th May 2013 at 3:06 AM. Reason: Added new wrappers
Default S3PE Version and Medieval Wrappers
So, I've been messing with some Wiki stuff thanks to ellacharmed setting me up an account, and setting up the basic pages. Take a look at it here, Medieval Wiki. There are no pages yet, but perhaps it will inspire some of you to work with me on getting it going. By myself it seems like a lot of work.

Anyway, part of what I've been trying to get ready has involved figuring out data formats for S3PE resources. Much of Medieval resources are the same, but a few have changed, and some are totally new. As such I've taken a few days to figure out a couple of wrappers for S3PE to work with Medieval files.

The wrappers only work with the current version of S3PE, and yes it seems to be working with Medieval once again. These wrappers have been tested a bit, but are very much a work in progress.

Copy the wrapper dll you wish to use to your S3PE installation folder. For me on Windows 7 (x64) it's "C:\Program Files\s3pe". Make sure to backup or rename the file extension of any resource handler you are replacing.

This is an updated version of velocitygrasses CASP wrapper. I've only included the 2.0 version which converts lesser versions to 2.0. Any TS3 CASP opened with this wrapper, changed and committed, will be converted to a Medieval CASP, and will be unusable with TS3. This wrapper also fixes BBLNs. Version 8 only, uses a special parser, whereas any other version uses the default parser. The code was incorrectly set to 8 or greater, and should have only been 8. Only a minor change by me, and rebuilt with the latest s3pi library. All credit goes to velocitygrass.

The is a version of velocitygrasses DTTB wrapper rebuilt with the latest s3pi library. All credit goes to velocitygrass.

The OBJD wrapper is the beginning to making custom objects. I've used it already to make some new objects with some basic changes (price, name, etc.). This wrapper only works for Medieval. It's due to the fact that the version number Medieval uses is the same as a Sims 3 version number, but the data is different. It also doesn't work for OBJD's in the FullBuild package. These all seems to be overwritten by ones in the DeltaBuild, but let me know if you find one that isn't. I've figured a bunch of the flags, and the stuff I haven't figured I've labeled as Unknown. Anything you figure out about the Unknown entries let me know. As I figure stuff out I'll update the wrapper.

VPXY (TS3 and TSM)
The VPXY wrapper works for both Sims 3 and Medieval Visual Proxies. These mainly will give you access to TGI containing model links. There are a few that don't work, but there are a few Sims 3 one's that don't work with the original wrapper.

These wrappers are still in testing stages, and may cause errors, so use them at your own risk. Also, be wise and back up your original wrappers.

Any questions, comments, bug reports, or ideas for other wrappers are welcome in this thread.
Download - please read all instructions before downloading any files!
File Type: zip VPXYwrapper.zip (34.9 KB, 760 downloads) - View custom content
File Type: zip OBJDwrapper.zip (34.9 KB, 706 downloads) - View custom content
File Type: zip CASPWrapper.zip (26.7 KB, 1426 downloads) - View custom content
File Type: zip DTTBWrapper.zip (6.1 KB, 686 downloads) - View custom content
Original Poster
#2 Old 16th May 2013 at 1:26 AM
So leave it to me to update within a few hours of my first post, sorry to those who've downloaded already. I've figured out most of the flags in the OBJD resource, and set any entry I haven't figured out as Unknown. Please redownload the OBJD wrapper for the fix.
Original Poster
#3 Old 16th May 2013 at 11:59 PM
I forgot to mention that the CASP and DTTB wrappers needed to be rebuilt with the latest s3pi library. These are the same wrappers we've all been using made by velocitygrass. The only change I made was to the CASP wrapper to be able to read Medieval BBLN resources. Simply changing a few cases where version eight or greater was used when version eight only should be used.

Have fun.
#4 Old 18th May 2013 at 9:15 PM Last edited by ChickieTeeta : 18th May 2013 at 10:09 PM.
I was just playing around with the objd wrapper.
Awesomeness, thank you so much for this....and the other ones of course, it's great to finally be able to update S3PE to the most recent version.
Thank you again, for all of them of course, but I am particularly taken with the shininess of the objd wrapper atm.

I wondered what to try out first. I went with paintings since I already know they can be made unique, and also because my castle is long overdue a 20 foot tapestry of my fave sim lol

What do you mean, 'get a life'! I'm a gamer, I have many lives.
Lab Assistant
#5 Old 21st May 2013 at 2:03 AM
Great work, Grim. I'm having the same problem with the DTTB wrapper, as I had with the original version by velocitygrass though. Whenever I try to add a new _XML 0x0333.. resource, it fails instantly with a NullReferenceException.

Can you fix it? And sorry for the error being in Danish, shouldn't matter though.
Original Poster
#6 Old 21st May 2013 at 9:20 PM
The error can easily be worked around, and that's probably the best solution right now. I may look into making it default to XML 1.0, but if you have an xml file it's really easy to create a new one with the wrapper as is.

Create your new XML 0333406c. When S3PE gives you the error dialog click Continue.

Now, right click on the new resource, and select Replace. Find you XML file, and the wrapper should load it as an XML 1.0. (Any change would make this step a default step for all new files).

If you want or need the file to be a DTTB resource, you can now click the grid button and import there the same XML, and it will be converted to binary.

So I could remove one really quick step. I probably will, but it's not on my high priority list. If you really want it, velocitygrasses code comes with his file. Mine is just a rebuild DotNET 4.0 version of his cs files.
#7 Old 6th Feb 2014 at 5:07 PM
When I use the DTTB wrapper to preview XML files, everything looks fine, but then they go back to being all messed up and undecipherable when opened in a text editor. How do I edit XML files?
Test Subject
#8 Old 19th Mar 2014 at 3:41 AM
i can't make a mod please help me
Test Subject
#9 Old 22nd Mar 2014 at 5:19 PM
Ive been having the same problem no matter what version of the S3PE and wrappers. I follow all the steps and even with yours, the grid button is still grayed out...idk what to do now i've tried everything.
Test Subject
#10 Old 3rd May 2014 at 3:24 AM
Originally Posted by yaydonna
Ive been having the same problem no matter what version of the S3PE and wrappers. I follow all the steps and even with yours, the grid button is still grayed out...idk what to do now i've tried everything.

Same here. Perhaps the wrapper is in need of a slight update? It has been quite some time since the last one.
Test Subject
#11 Old 25th Sep 2014 at 12:15 AM
Please fix this asap... I tried everything now... Old versions, velocity's wrappers, and now the new version with these and everytime result is the same.
Either it's as if I never implemented the wrapper at all, or the buttons are grayed out! Pls pls help with this
#12 Old 25th Sep 2014 at 1:14 AM
All of the wrappers work fine for me with the most current stable version of s3pe. Make sure you are installing the wrappers into the main folder of where you have S3PE installed in.

You can find my Sims 3 Mods at TFM's Sims Asylum .
Test Subject
#13 Old 25th Sep 2014 at 1:26 AM Last edited by Maoraw : 25th Sep 2014 at 1:27 AM. Reason: spellmistake
Originally Posted by bluegenjutsu
All of the wrappers work fine for me with the most current stable version of s3pe. Make sure you are installing the wrappers into the main folder of where you have S3PE installed in.

I have, and nothing seems to work.
I've done everything as written and more to:
I downloaded the newest S3PE I download the CASP wrapper
I go into the installation folder in Program Files/s3pe/
I renamed the old dll s3pi.CASPartResource._dll (so it doesn't get loaded)
I inserted the new one by grimreefer

Aaaand the grid button is grayed out when i test it with anubis hair.

I tried installing an older version og s3pe, along witht he velocitygrass .dll's, I tried both 32 and 64 bit on all versions. I tried the version ChickieTeeta suggested in the other thread, along with downloading the right CASPart.dll, and yet nothing works.I have no clue what to do... Before I put in the wrapper, I can open the grid one, but the medievalprofession thing does for obvious reasons not show... The wrappers will simply not inject to ANY of the S3PE versions and I don't know why.
I'm running Windows 7, on lowest security, basically I have administrator priviliges for everything
What in the world am I doing wrong?
#14 Old 25th Sep 2014 at 1:20 PM
Did you try moving the s3pi.CASPartResource.dll file into a different folder instead of just renaming it? I put the dttb, casp and objd wrappers in the S3PE install folder and move out the original ones to another folder and the wrappers work for me. Try using the dttb wrapper with the casp one and see if that helps you. Otherwise, I don't know what is causing your trouble since I am not having any problems with editing files for the medieval game with the wrappers in the first post of this thread.

You can find my Sims 3 Mods at TFM's Sims Asylum .
Test Subject
#15 Old 25th Sep 2014 at 2:34 PM Last edited by Maoraw : 25th Sep 2014 at 2:37 PM. Reason: Details
I did, and it's the same problem, here's what I'm doing in pictures:

On the first picture here, I'm showing the resources I'm going to use and the version of S3PE (newest)

Here I installed it with basic settings (only 2 first checked off, I tried with 3 before tho')

Here I went into the installation folder. As shown on the picture the original CASPwrapper is 81kb

I inserted the one by grimreefer, and the other I took out into my downloads ("overfřrsler", in danish) folder so it definitely shouldn't be put to use by the program.

Testing the program now... Doesn't work....

I took out the other resources (as suggested, I accidentally overwrote the s3pi.RCOLChunks.dll one, so that's why it's not in the Downloads folder. The DTTB one didn't even have a resource before, so it didn't overwrite anything as far as I could see...
Despite all these efforts, still doesn't work.
I tried with velocitygrass' CASPwrappers too (40,5kb, both tried with the 32 bit and 64 bit) to no avail.
I have absolutely no clue what to do from here.
Is there any chance that any of you who got it working could copy your installation folder into a zip folder to download?
I'm just completely clueless as to what I can do
#16 Old 25th Sep 2014 at 2:47 PM
Out of curiosoty, how long have you had the version you're using?

What do you mean, 'get a life'! I'm a gamer, I have many lives.
#17 Old 25th Sep 2014 at 9:53 PM
The version of s3pe? I'm using s3pe_14-0113-1123, which has a date from January of this year. http://www.den.simlogical.com/denfo...hp?topic=2519.0 I don't have the latest test version, but one that was right before the latest. It works great with the wrappers. I've edited CASP, XML and OBJD files with this version of S3PE and the wrappers from the first post above.

I had thought my version was the latest stable version since there was a new test version released after, but I guess mine is also a test version. I've been making mods for the Sims 3 game for a long time with this version and haven't run into any trouble with it, either.

You can find my Sims 3 Mods at TFM's Sims Asylum .
#18 Old 26th Sep 2014 at 9:24 AM
Thank you for your reply.
I was using this on my old hard-drive, which is dying an excruciatingly horrible death, and it all worked as it should.
On my new hard drive (which has been in use since May 2014), I downloaded this version of S3PE again and have exactly the same problem as Maoraw. I try periodically to get it to work, but it always looks exactly the same as Maoraw's pics.
s3pe_12-0222-2102 still works just fine with Velocity Grass' wrappers, so I've had to go back to using that one. I don't mind so much having to go back to extracting xmls just to see what's in them, but it also means going back to using a hex editor for objects :*(

What do you mean, 'get a life'! I'm a gamer, I have many lives.
#19 Old 26th Sep 2014 at 12:22 PM Last edited by bluegenjutsu : 26th Sep 2014 at 12:43 PM.
That's strange that it's different on different hard drive types, but I guess as long as one of the versions work with the wrappers then it's okay. You're welcome.

*I've posted a pic showing that the CASP wrapper is working in the S3PE program that I have installed.

You can find my Sims 3 Mods at TFM's Sims Asylum .
Test Subject
#20 Old 26th Sep 2014 at 3:48 PM Last edited by Maoraw : 26th Sep 2014 at 4:05 PM.
Well... I tried with both the s3pe_12-0222-2102 and velocitywrappers (32 first, then 64bit dll)
And I tried the s3pe_14-0113-1123 with grimreefers dll... Thanks for trying guys, I'm not sure if it's my harddrive, it got 500GB and is "NTFS" whatever that means...

I even tried both things that worked for you guys on my other computer, running windows XP, 80GB (old harddrive) but also "NTFS"
Same exact problem...

I guess I'm just not supposed to be modding :/
Test Subject
#21 Old 8th Nov 2015 at 7:50 PM
Hi, by me it's doesn't work yet :/ only one change : a little bug with the music. How do we know the version of S3PE ? Thank you for helping me
Test Subject
#22 Old 1st Feb 2016 at 4:17 AM
I hate to bump a thread, but nobody ever answered this. I'm having the exact same issues as Maoraw - the Grid button is always greyed out regardless of version or wrapper. I've tried the same things being suggested here. I just wanted to try and convert some old hair to Sims Medieval hair, but this wrapper seems busted as hell and appears to have been so for some time, but on the off chance someone ever got it working, the help would be appreciated.
Back to top