Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

New Creator Theme: Elders! - posted on 1st Sep 2018 at 11:43 AM
Replies: 11 (Who?), Viewed: 1125 times.
Test Subject
Original Poster
#1 Old 25th Mar 2018 at 10:53 PM
Default No Lots Would Load, Now Neighborhood is Wiped?!
Hi all!

Firstly, if this has been answered before, I apologize. I looked through the forums for a bit though and didn't find anything.

Necessary background info: I've been playing Sims on & off for about 2 years. I'm playing Sims 2 off of a disc, on a Toshiba Satellite laptop running off of Windows 10. I'm not very active in the TS2 community, but have enough basic computer knowledge to know how to download CC and things...but that's about it. I'm not too tech-savvy. I'm playing in Veronaville, with CC enabled.

Now, on to the issue...
My sims game was working fine, everything was great, all my CC was working flawlessly, etc.
Now, two days ago, I came home on my first day of spring break, pumped to play TS2! But no lots would load. Suddenly, I couldn't play my most-frequently-used family, I couldn't load lots with no family on them, I couldn't even load the lots that came with the game. It wouldn't freeze when it came to the family-loading screen, it would look like it was loading, but it would never actually load. And I would let it sit for over an hour at a time just to see if it was slow-loading. No dice.

After exiting out of the game, restarting my computer, clearing caches, etc. several times, nothing was changing. I permanently deleted all CC downloaded between the last successful play and the day of the error (unless it is somehow hiding in some files, is that possible?). I used the CleanInstaller to look though previously used CC (that had given me no issues in the past), and deleted any duplicates and any red-lined files, in addition to all the "new" CC previously mentioned. I then loaded the game again, and was still having the same issue. So I closed it again, and tried to run it with CC disabled. CC was still showing up, so after some more internet digging, I tried moving Downloads and Neighborhoods to the desktop, and running the game again.

After that, it's like it reset everything! Which, maybe that was the point? The instructions weren't very clear. Anyway, I moved those files back to the Documents> EA Games> The Sims 2, thinking (& hoping) that would pop everything back into place, but....no. Now ALL my stuff is gone! Veronaville loads as if I had just installed the game!

I'm both exhausted/braindead from days of internet digging, and rather devastated because I was deeply attached to a family and home that I had been working on for months. If anyone with more experience than me could help me figure out how to restore my game, if possible, I would be beyond grateful.

Thanks
Advertisement
Test Subject
Original Poster
#2 Old 25th Mar 2018 at 11:21 PM
UPDATE: All my lots have magically popped back into existence, but I still can't open them. Family loading screen just sits there.
Needs Coffee
staff: moderator
#3 Old 25th Mar 2018 at 11:35 PM
Often hood vanishing is the end result of hood corruption. Do you know about corruption and have you done things to corrupt your hood?
Never delete sims, never move sims between hoods, never place an occupied house into the bin. Do you have the main mod fixes? No unlink on delete, no corrupt death, creature fixes (if you play vampires) the bat Box, No Sim Loaded with Smarter EP Check?

Do you have backups and have you run Hood checker? Just so that we know if you are new to corruption or already know and take steps to avoid it.

"I dream of a better tomorrow, where chickens can cross the road and not be questioned about their motives." - Unknown
~Call me Jo~
Instructor
#4 Old 26th Mar 2018 at 9:25 AM
If you use the Maxis Veronaville, it's already corrupted, so even if you didn't do any of the things jo mentioned, this might still happen.

The thing you did where you moved your neighborhoods to the desktop was supposed to reset everything, so nothing strange there. Obviously it doesn't fix your problem.

It's possible to restore a neighborhood even with your current state, it takes some time but isn't complicated.

You can find the mods jo mentioned here: http://modthesims.info/showthread.php?t=532696 if you don't already have them.
Test Subject
Original Poster
#5 Old 27th Mar 2018 at 12:05 AM
Thank you both!

I don't think I've done anything to corrupt my hood, but it's possible. I haven't got those mod fixes, but I will download them as soon as I can. They're getting stuck at the moment, as sometimes my laptop will download .zip & .rar files and sometimes it won't. So far, today has been an "it won't" day. Believe me, I wish I knew the solution to that too.

Thanks for pointing me in the right direction. I will keep you updated!
Mad Poster
#6 Old 27th Mar 2018 at 12:13 AM
What do you mean, that the computer won't download zip/rar files? Do you get errors? Can't you find them when downloaded? Does your antivirus (if you have) block the files? Anything else?
Needs Coffee
staff: moderator
#7 Old 27th Mar 2018 at 12:40 AM
Without no unlink on delete you don't have to do anything because the game itself can randomly delete a grave causing more corruption. if you have nothing else that one is the most important.

"I dream of a better tomorrow, where chickens can cross the road and not be questioned about their motives." - Unknown
~Call me Jo~
Test Subject
#8 Old 27th Mar 2018 at 1:34 AM
I lost a neighborhood with those exact "symptoms" twice before understanding hood corruption. During normal gameplay, if you don't use some mods to help you to avoid it (as already pointed), your hood can implode. Maxis' fault. I believe Maxis never figured people would get so attached to Sims 2 game, so they didn't bothered to make sure the game was stable (they even let us a lot of premades full of corruption or easily corrupted to start our games).
I wish you luck with your game, and welcome to the fascinating world of avoid hood corruption. The good part is that while Maxis did a lousy job on many things concerning Sims 2, there are a lot of simmers and modders that did (and still do) many good and useful tools to give us the much needed unofficial support. Read them, download them, read more. And happy simming.
Instructor
#9 Old 27th Mar 2018 at 8:51 AM
Most of those essential mods are to protect your future neighborhoods, so don't expect them to fix your current situation. You should still install them, just keep that in mind.

The first thing you can do is run HoodChecker (linked in the essential mod thread). Have it check your neighborhood and attempt to remove any problems it finds. There will be a lot, since it's an old neighborhood, but most of it it probably harmless and can be fixed. If you run it again, ideally it shouldn't find anything, but there probably will be some missing character files.

It's pretty unlikely to happen, but if you're really lucky, your neighborhood will work again after you do this. In that case, make sure you make regular backups and run HoodChecker once in a while and your hood should still have some years left. If it doesn't, it's still possible to save your sims.
Field Researcher
#10 Old 27th Mar 2018 at 3:35 PM
Quote:
Originally Posted by Lundquist00
UPDATE: All my lots have magically popped back into existence, but I still can't open them. Family loading screen just sits there.


That's usually caused by something on the lot continuously throwing an error, turn testing cheats on from the neighbourhood before loading the lot. If an error message appears the only option that'll get you back into the lot is 'Delete'.
Test Subject
Original Poster
#11 Old 1st Apr 2018 at 4:02 AM
Quote:
Originally Posted by simmer22
What do you mean, that the computer won't download zip/rar files? Do you get errors? Can't you find them when downloaded? Does your antivirus (if you have) block the files? Anything else?


Most of the time on this site specifically, downloaded files either download instantly (yay), or they get stuck within the first 20% of downloading and never finish (even after retrying, opening in an incognito tab, right-clicking and choosing "save as" instead of just clicking- all supposed fixes for this issue). When trying to download cc files (as zip or rar) from any other websites, such as Sims File Share, I have never been able to download them. They will "download" extremely slowly, usually getting stuck at 0.1MB/sec, before running into a network error.

I'm hesitant to chalk this up to a slow internet connection, because my internet usually works fine for everything else in my home; streaming video, loading webpages, etc.
Test Subject
Original Poster
#12 Old 1st Apr 2018 at 4:02 AM
Quote:
Originally Posted by Chris Hatch
That's usually caused by something on the lot continuously throwing an error, turn testing cheats on from the neighbourhood before loading the lot. If an error message appears the only option that'll get you back into the lot is 'Delete'.


Turning the testing cheats on works! thank you!!
Back to top