Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

Theme Catchup2018 - posted on 1st May 2018 at 1:50 PM
Replies: 96 (Who?), Viewed: 9640 times.
Page 4 of 4
Instructor
#76 Old 29th Jan 2018 at 7:40 AM
Quote:
Originally Posted by Honeywell
@Quaxi I have a problem with meshes. When cloning an object the GMDC isn't included and when trying to open them from an existing package I get this error: is not a valid Win32 application. (Exception from HResult: 0x800700C1)

It's been a long time since I've setup SimPE though so I might be forgetting something I should do. I linked to my system files and DDS utilities and my computer is 64bit if that matters.


I added 64-Bit support, but maybe so legacy libs are stille 32-Bit. I'll have a look. Thanks for reporting.

Just as an info about the delay: I am currently trying to convince EA to upgrade my physical discs to a origin download.
I don't use Windows for quite some time now and have it running in BootCamp on my mac without any optical disc. As soon as I am able to install a Sims 2 game, I'll be able to narrow down these types of problems
Instructor
#77 Old 31st Jan 2018 at 3:41 PM Last edited by Quaxi : 3rd Feb 2018 at 4:28 PM.
Hi all.

Would you please have a go with this Version:
- GMDC should load fine again
- Should Pick up The Sims 2 Ultimate Collection correct (Tested on 64-Bit Windows 10)
Mad Poster
#78 Old 31st Jan 2018 at 4:08 PM
I am wondering, I am on Win 7 64-Bit. I am still using discs (No UC)
I downloaded your new .dll posted a few days ago. My SimPE is back to normal. I can make/clone new objects, GMDC works just as before. I can recolor, get new GUIDs, browse Neighborhood...
Should I too, download and try this new version, or should I keep using 0.73.44 version?
Thank you.

Je mange des girafes et je parle aussi français !...surtout :0)

Find all my old MTS Uploads, on my SFS ;)
Instructor
#79 Old 31st Jan 2018 at 7:38 PM
Quote:
Originally Posted by Rosebine
I am wondering, I am on Win 7 64-Bit. I am still using discs (No UC)
I downloaded your new .dll posted a few days ago. My SimPE is back to normal. I can make/clone new objects, GMDC works just as before. I can recolor, get new GUIDs, browse Neighborhood...
Should I too, download and try this new version, or should I keep using 0.73.44 version?
Thank you.


I was wondering the same thing (I'm on Win 7 32-bit and I'm still using disc, too.) I was also wondering if all of my plug-ins and templates will work with the newer version.
Scholar
#80 Old 1st Feb 2018 at 1:10 AM
@Quaxi

Thanks for adding 64-bit support, that helps quite a bit in helping speed up processing for SimPE.

So I'm getting this message when trying to access the GMDC resource in SimPE. The message says that Managed DirectX isn't installed (even though it is and q73 recognizes it). Here's the message:



I'm guessing that SimPE q75 will need some fixing to recognize it. Or maybe there's something on my end that needs to be done?

Check out "The Adventures of Superman" Digital Comic Books for fun with Superman in The Sims 2.
See what images I have posted on DeviantArt as well related to The Sims 2 and designs.
Check out My Website to see my superhero uniform creations for The Sims 2. THANKS!!!
Instructor
#81 Old 3rd Feb 2018 at 2:14 PM
Quote:
Originally Posted by Rosebine
I am wondering, I am on Win 7 64-Bit. I am still using discs (No UC)
I downloaded your new .dll posted a few days ago. My SimPE is back to normal. I can make/clone new objects, GMDC works just as before. I can recolor, get new GUIDs, browse Neighborhood...
Should I too, download and try this new version, or should I keep using 0.73.44 version?
Thank you.


No, there is nothing new in this release. I am just trying to create a new release package that includes all the fixes to make it easy to install.

You can give the new Version a try. It extracts to a new Folder and should not compromise your existing Installation.
Mad Poster
#82 Old 3rd Feb 2018 at 2:19 PM
Thank you for the precision, and everything else.

Je mange des girafes et je parle aussi français !...surtout :0)

Find all my old MTS Uploads, on my SFS ;)
Instructor
#83 Old 3rd Feb 2018 at 4:28 PM
Next try

- GMDC shoudl work again
- NPC should get recognized
- Sanity check for ultimate Collection should work
Download - please read all instructions before downloading any files!
File Type: 7z SimPe_075f_qa.7z (4.11 MB, 223 downloads) - View custom content
Scholar
#84 Old 3rd Feb 2018 at 9:22 PM
Thank you, the Unknown NPCs now have names associated with them, and GMDC works fine to display the meshes. Perfect!

Do you happen to know why SimPE didn't recognize them in the past? I see that most known NPCs had thumbnails to them, and it correctly pointed to "object.package"



Now that the unknown NPCs are known by the names, I thought I'd check them, and I see that they're not pointed to an "object.package"



Was there a reason why? Just curious to know how you programmed SimPE before to recognize those NPCs.

Check out "The Adventures of Superman" Digital Comic Books for fun with Superman in The Sims 2.
See what images I have posted on DeviantArt as well related to The Sims 2 and designs.
Check out My Website to see my superhero uniform creations for The Sims 2. THANKS!!!
Mad Poster
#85 Old 4th Feb 2018 at 4:52 AM
I go missing for two weeks and I come back to Quaxi being back, guid issue fixed, 64 bit version of SimPE, UC pick up... I AM SO EXCITED I CAN NOT EVEN! Thank you times a billion Quaxi for being willing to come back to something you did 10 years ago, and not only fix an error but give us extra on the side. The Sims community never ceases to amaze me with the wonderful people that it contains, be it now or 10 years ago.

And also thank you very much to Kalkwerk and julsfels for figuring out a way to contact Quaxi. We all owe you two a great debt for making TS2 creating easier for all the creators who are starting out now, and for giving all of us a chance to keep our wonderful modding program with us as long as possible.

Will help with testing once I get back home to my simming pc.

Quote:
Originally Posted by CatOfEvilGenius
May I quote you for my intro programming students? I think they don't believe me when I say comment and document your code because you may want to look at it years from now. Thank you much for being willing to go look at that code.


This made me laugh. Wish I had you as a teacher! I didn't document anything when I started out, and now when I get a report of a conflict or something on an old mod I go in and have no idea what on earth is going on and have to start over from scratch. Nowadays I try to remember to document exactly what the code does and how, and how I changed it, to make it easier for myself when I end up looking at it two years down the line. Or a month

If you have questions on how to use SimPE or WW, you're welcome to PM me.
just a girl
#86 Old 5th Feb 2018 at 1:12 PM Last edited by Lamare : 5th Feb 2018 at 9:01 PM.
Thank you very much for fixing GUID registration. I use your fix in 0.73.44-QA and it's a huge improvement from maintaining a list manually in text editor.

I tried the new version. UC user here. (Edit: and Windows 7)

1. I like that it sorted out system folders on its own. The paths look really weird and non-existent, but it seems to work...
2. I like that PJSE plugin seems to pull up the right resources from the latest version of the game. It used to pull base game resources sometimes, and op-code chooser offered two versions of each BHAV if they were different. (I guess it's related to system folders.)
3. Design notes. Object workshop doesn't want to appear in the lower section where it used to be (along with plugin view, finder, etc). Instead there's new ManagedDockPanel18 that I've never seen before. Also, I don't like new "Office 2003" style all that much. I got used to the old one in 0.73.44-QA. It was blue and smooth a-la Windows 7. Now it's gray and blocky a-la Windows XP. It's a minor thing though. Comparison: http://www.modyourpanties.com/hosti...-comparison.jpg
4. Question: Is it OK to change language by deleting language folders from SimPE's installation folder? That's what I used to do before because it was the only way.
5. Got an error trying to drag and drop a package from desktop into SimPE window.

I've spent little time testing, but I'll do more. Thanks again for fixing SimPE and making it in the first place. Great tool.
Dancing Flamingo
staff: administrator
#87 Old 5th Feb 2018 at 1:31 PM
Quote:
Originally Posted by Lamare
Thank you very much for fixing GUID registration. I use your fix in 0.73.44-QA and it's a huge improvement from maintaining a list manually in text editor.

3. Design notes. Object workshop doesn't want to appear in the lower section where it used to be (along with plugin view, finder, etc). Instead there's new ManagedDockPanel18 that I've never seen before. Also, I don't like new "Office 2003" style all that much. I got used to the old one in 0.73.44-QA. It was blue and smooth a-la Windows 7. Now it's gray and blocky a-la Windows XP. It's a minor thing though. Comparison: http://www.modyourpanties.com/hosti...-comparison.jpg


I was just coming to make a note of this, object workshop location. It kinda is a big deal to me not being able to move it around.
ETA: I would be okay with it if it took up top to bottom on the right side.

As to the color style Lamare, have you tried changing it in preferences?

ETA: The drag and drop issue I have as well, however I just copied the hoods.xml from the last version into this one.
just a girl
#88 Old 5th Feb 2018 at 1:36 PM
Posting just to see what HugeLunatic had to say because I sometimes can't see new posts.

Ok, now I see it.

Quote:
Originally Posted by HugeLunatic
As to the color style Lamare, have you tried changing it in preferences?

Yes. I've tried a few other styles and each time restarted the program. They are all blocky, just slightly different colors and details. On my screenshot, it is the same Office 2003 style, but it looks different in 73.44 and 75.1. Again, it's not a biggie, I can overcome aesthetically ugly buttons. It's hard, but I can do it!
Top Secret Researcher
#89 Old 5th Feb 2018 at 2:11 PM
It took a lot of time and opening and closing the little frames, but I was eventually able to grab object workshop and put back at the bottom. I get an error when I try to clone an object. I'm using UC and Windows 10 home.



.NET Version:
2.0.50727.8825
Not actually evil.
#90 Old 5th Feb 2018 at 7:56 PM Last edited by CatOfEvilGenius : 5th Feb 2018 at 10:30 PM.
Quote:
Originally Posted by omglo
It took a lot of time and opening and closing the little frames, but I was eventually able to grab object workshop and put back at the bottom.


I can never figure out docking and docked stuff. How on earth did you do it? I too would like object workshop on the left or the bottom, not on the right.

[edit] OMG I think I moved it! It's now in the lower left corner. Let's see if it stays there...

---------------------------

@Quaxi - Thank you so much! Testing version 75f on Win 10 Pro 64 bit 1709 with Ultimate Collection.

* paths to ep's and sp's were correctly set, yay
* gmdc mesh preview works great

1) When opening a mesh package file I made some years back, I got a strange error saying hoods.xml could not be loaded.
Tried opening another mesh file, worked fine. Went back to open the first one, to reproduce the error and screenshot,
but it opened fine that time, no error. Not sure what's going on there.
[edit] Seems to appear the first time I try to open a file, and then not for any other file.



2) Not sure why managed directx is a separate download in extras. I create clothing meshes. Never had to do anything
with managed directx before that I recall. Is it for something else? And what would I do with the simpe_mdxredist.msi
file if I did download it? Put it in the folder with SimPE?

3) I vaguely recall years back having to set a path somewhere in SimPE so it would find Happy Holiday Stuff.
Is that still necessary?

Please spay or neuter your pets. --- Cat Music Video! --- my meshes
just a girl
#91 Old 6th Feb 2018 at 10:43 AM
More notes from me. (UC and Windows 7.)

6. BCON and BHAV labels are nowhere to be seen. Like when I try to get global constant for setting object category, there are no labels for values. I remember some constants and values by heart now, but not all of them, so this makes modding a lot harder. Did I forget to do something we need to do on setting up? I know about GUID index that I must create it myself, but labels were there automatically in 73.44 (I think).
7. File - Open In - finds only base game folder. I guess it has to do with non-existent paths I was talking about a few of posts above. This option didn't work for me in 73.44 either, so I'm used to it, but I thought I'd say.

Anything I've said so far is not nearly as important as labels. Without labels - I'm blind.
Lab Assistant
#92 Old 6th Feb 2018 at 2:06 PM
Quote:
Originally Posted by CatOfEvilGenius
Not sure why managed directx is a separate download in extras. I create clothing meshes. Never had to do anything with managed directx before that I recall. Is it for something else? And what would I do with the simpe_mdxredist.msi
file if I did download it? Put it in the folder with SimPE?


@CatOfEvilGenius - An MSI is a Windows Installer, so just open/run it and follow the prompts to install managed directx. I think it's a separate download because it's Microsoft created and then just being redistributed as a SimPE add-on. It has its own licence agreement, for instance.

Not sure exactly what functionality it enables, as I don't do anything with meshes. I only installed it so I could look at everything in a package, and not get bugged by the "you need to install this message" if I clicked in the wrong place.
Lab Assistant
#93 Old 11th Feb 2018 at 1:50 PM
Quote:
Originally Posted by Lamare
More notes from me. (UC and Windows 7.)

6. BCON and BHAV labels are nowhere to be seen. Like when I try to get global constant for setting object category, there are no labels for values. I remember some constants and values by heart now, but not all of them, so this makes modding a lot harder. Did I forget to do something we need to do on setting up? I know about GUID index that I must create it myself, but labels were there automatically in 73.44 (I think).
7. File - Open In - finds only base game folder. I guess it has to do with non-existent paths I was talking about a few of posts above. This option didn't work for me in 73.44 either, so I'm used to it, but I thought I'd say.

Anything I've said so far is not nearly as important as labels. Without labels - I'm blind.


If you haven't already found your labels: they are inside some package-files in your SimPE 73.44 program folder : SimPE 73.44\Data\Plugin\pjse.coder.plugin\includes. You only have to copy all the packages to SimPE 0.75 \Data\Plugin\pjse.coder.plugin\includes (which is in fact empty in the archive-file (.7z)).
Field Researcher
#94 Old 14th Feb 2018 at 1:08 PM Last edited by Sunrader : 20th Feb 2018 at 2:20 AM.
First, I'm super happy that @Quaxi is back, seriously, I cried. Big sloppy, happy tears. Thank you to those involved in getting in touch and to Quaxi. It must be fun to find out everyone is still enjoying your work.

Possible issue with new version:
I downloaded the file on Quaxi's post#83, but when I try to save an export file in the SimSurgery plugin, the entire program (SimPE) just closes.
It still works normally in the older version, so, at least, I know I still know how to export a file there. Is there something new I need to know?

EDIT: This issue turned out to be my virus scanner quarantining SimPE.exe.
Test Subject
#95 Old 17th Feb 2018 at 9:42 PM
Thank You @ Quaxi!!! <3
Field Researcher
#96 Old 3rd Mar 2018 at 11:40 PM
THis is excellent! Thank you Quaxi
Instructor
#97 Old 4th Mar 2018 at 7:53 AM
This is really great! Thank you, Quaxi.
Page 4 of 4
Back to top