Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

Nysha's New Creators for July - posted on 1st Aug 2018 at 9:00 AM
Replies: 11 (Who?), Viewed: 659 times.
Test Subject
Original Poster
#1 Old 30th Jan 2018 at 3:04 AM

This user has the following games installed:

Sims 2, University, Nightlife, Open for Business, Pets, Seasons, Bon Voyage, Free Time, Apartment Life
Default Help with pink flashing and the sgr files?
So I've recently gone back to the Sims 2 on a new computer with a new graphics card. My game has severe pink flashing immediately when I load a hood up. I looked at some tutorials, videos, and guides, and found that I likely need to edit the sgr files to force the game to use the proper amount of memory and to recognize the card, so I started fiddling around with it. When I next loaded it, the flashing was even worse! So, apparently, I don't know what I'm doing, and I'd like some help understanding what needs to be changed in my sgr files.

I've attached my DxDiag file, as well as my VideoCards.sgr , and GraphicsRules.sgr
Download - please read all instructions before downloading any files!
File Type: zip Smop95 config and sgr.zip (25.3 KB, 23 downloads) - View custom content
Description: contains my dxdiag, GraphicsRules.sgr, and VideoCards.sgr
Advertisement
Test Subject
#2 Old 30th Jan 2018 at 3:40 AM
Hi smpo95. It looks like you might be another member of the "Windows 10 ate my game" club, which seems to be happening to some players after the most recent Windows 10 update, 1709. What's happening in your game sounds exactly like what is happening in mine. There are already quite a few threads going about the issues:

http://www.modthesims.info/showthread.php?t=605987
http://www.leefish.nl/mybb/forumdisplay.php?fid=21
Lab Assistant
#3 Old 30th Jan 2018 at 5:09 AM
@smpo95 Mortia might be right. You may be another victim of the Windows 10 debacle. Although I did see a couple errors in your video card and graphic rules files. First you need to delete out the Nvidia in front of your card name in the video card file, so the game will recognize it. Like so



Also you have the texture memory set to 6000. This is WAY to high for your graphics card. Your DxDiag has the texture memory for your 960 card at 4062 so you will want to change that. When I had a 960 card I just had it set at a generic 1744. So if lowering it to 4062 doesn't help, then you can try that. Also make sure your graphics card drivers are up to date. When I had a 960 I also had purple/pink flashes everywhere until I edited my files correctly. So with any luck, this will be your only issue. If changing these things doesn't work, cry.... because nobody has come up with a fix for Windows eating their game.

I love your machine name by the way.
Test Subject
Original Poster
#4 Old 30th Jan 2018 at 6:40 AM
Quote:
Originally Posted by Jules1111
@smpo95 Mortia might be right. You may be another victim of the Windows 10 debacle. Although I did see a couple errors in your video card and graphic rules files. First you need to delete out the Nvidia in front of your card name in the video card file, so the game will recognize it. Like so



Also you have the texture memory set to 6000. This is WAY to high for your graphics card. Your DxDiag has the texture memory for your 960 card at 4062 so you will want to change that. When I had a 960 card I just had it set at a generic 1744. So if lowering it to 4062 doesn't help, then you can try that. Also make sure your graphics card drivers are up to date. When I had a 960 I also had purple/pink flashes everywhere until I edited my files correctly. So with any luck, this will be your only issue. If changing these things doesn't work, cry.... because nobody has come up with a fix for Windows eating their game.

I love your machine name by the way.


Lol thanks My cousin named it that when he helped build it for me, and I kept it.

Thanks for the advice on thosr sgr edits. I just made those changes so I'll report back when the game loads (it usually takes 30 - 45 mins).
Test Subject
Original Poster
#5 Old 30th Jan 2018 at 7:23 AM
Ok, game loaded, and no pink flashing yet. A few times it did start without it but it would show up after loading a lot or two. So, hopefully I'm good.
Lab Assistant
#6 Old 30th Jan 2018 at 3:49 PM
Quote:
Originally Posted by smop95
Ok, game loaded, and no pink flashing yet. A few times it did start without it but it would show up after loading a lot or two. So, hopefully I'm good.


I hope so! Glad you got it working again, though the after loading a lot or two thing is strange.
Not actually evil.
#7 Old 30th Jan 2018 at 4:06 PM
Flashing pink soup may be fixed, at least for a while, by changing your in game texture setting from high to medium, then back again. This forces the game to reload textures. If you're looking at lots of lots in a neighborhood, you can try setting the fade distance and view distance to medium or small instead of high. You can turn lot decorations off. This lessens the demands on texture memory since you're not rendering as many neighbor lots and neighbor objects. Thanks to my fellow simmers for suggesting this to me, it works in my game.

PS - Kiri/celekiriedhel also suggest setting lighting to medium and turning reflections off unless you're looking in a mirror. I also set graphics effects to medium.

PPS - You can also get really drastic and turn off neighbors, don't render neighbor lots at all. Then do textures high/medium/high, and the pink soup should go away for a while.

@Jules1111 - I get pink soup on community lots, with many sims, and many neighbor lots being rendered. I'm guessing that's what's going on with smop too. Less stuff to render on a home lot, less sims, usually playing zoomed in more, not seeing so many neighbor lots.

Please spay or neuter your pets. --- Cat Music Video! --- my meshes
Test Subject
Original Poster
#8 Old 30th Jan 2018 at 11:10 PM
Well after further testing, the pink flashing DOES show up, but only after heavy texture loading (i.e, after loading "change appearance" or buying clothes). So, that's a big improvement over immediate flashing.
Lab Assistant
#9 Old 31st Jan 2018 at 2:33 AM
Quote:
Originally Posted by smop95
Well after further testing, the pink flashing DOES show up, but only after heavy texture loading (i.e, after loading "change appearance" or buying clothes). So, that's a big improvement over immediate flashing.


Well that's better I guess. You can play around with the texture memory to see if you can get it any better, just don't go over 4062. Or like Cat said, you can just change the settings in game and then change them back.
Test Subject
Original Poster
#10 Old 31st Jan 2018 at 3:31 AM
Quote:
Originally Posted by CatOfEvilGenius
Flashing pink soup may be fixed, at least for a while, by changing your in game texture setting from high to medium, then back again. This forces the game to reload textures. If you're looking at lots of lots in a neighborhood, you can try setting the fade distance and view distance to medium or small instead of high. You can turn lot decorations off. This lessens the demands on texture memory since you're not rendering as many neighbor lots and neighbor objects. Thanks to my fellow simmers for suggesting this to me, it works in my game.

PS - Kiri/celekiriedhel also suggest setting lighting to medium and turning reflections off unless you're looking in a mirror. I also set graphics effects to medium.

PPS - You can also get really drastic and turn off neighbors, don't render neighbor lots at all. Then do textures high/medium/high, and the pink soup should go away for a while.

@Jules1111 - I get pink soup on community lots, with many sims, and many neighbor lots being rendered. I'm guessing that's what's going on with smop too. Less stuff to render on a home lot, less sims, usually playing zoomed in more, not seeing so many neighbor lots.


Well, I actually get it anywhere, including hood view. But I will try turning some graphics down, and see.
Not actually evil.
#11 Old 13th Feb 2018 at 11:00 PM
@smop95 - After several weeks of testing by several folks at leefish, we think it may be best to NOT use compatibility mode at all, turn it off if you've been using it. Also, if you have been using -CPUCount:1, don't do that either unless it was improving things. I'm using a noCD exe with the 4gb fix. Game has been stable and not flashing pink for several days now. Took much hairpulling to figure out how to get there.

Please spay or neuter your pets. --- Cat Music Video! --- my meshes
The Great AntiJen
staff: moderator
#12 Old 14th Feb 2018 at 5:12 PM
Quote:
Originally Posted by CatOfEvilGenius
@smop95 - After several weeks of testing by several folks at leefish, we think it may be best to NOT use compatibility mode at all, turn it off if you've been using it. Also, if you have been using -CPUCount:1, don't do that either unless it was improving things. I'm using a noCD exe with the 4gb fix. Game has been stable and not flashing pink for several days now. Took much hairpulling to figure out how to get there.

When you say -CPUCount-1 - has that been added to the shortcut?

tflc is my tumblr with uploads not uploaded here: https://www.tumblr.com/blog/tflc

Polgannon: Who Murdered Blaise Penhaligan?
(3rd ed. neighbourhood now available with corrections). Poll: http://strawpoll.me/6689876

Thread for yakking about making TS2 stuff
Back to top