Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

Nysha's New Creators for July - posted on 1st Aug 2018 at 9:00 AM
Replies: 6 (Who?), Viewed: 961 times.
Test Subject
Original Poster
#1 Old 14th Feb 2018 at 5:27 PM Last edited by BDEmoTrash : 14th Feb 2018 at 7:53 PM.

This user has the following games installed:

Sims 3, World Adventures, Ambitions, Late Night, Generations, Pets, Showtime, Supernatural, Seasons, University Life, Island Paradise
Default Mods won't work even after following every step!
So, for the last few days I have been trying to install mods but it's just not working. I've tried to follow everything I could find and still nothing is showing up on my Sims game.

I'm on a PC, Windows 10, and my game version is 1.67. I have put the Mods folder in the Documents/ElectronicArts/TheSims3 folder and in there I have put the Resource.cfg file, Overrides folder and Packages folder. In the Packages folder I've put the no intro mod so I could see if it would work. Everything is unzipped and I've also deleted all the cache, and still it won't work and I don't understand why.

Here are screenshots of what it looks like, can anyone tell me what I did wrong because I don't get it:
https://ibb.co/duYsd7
https://ibb.co/cxuXd7
https://ibb.co/ntjXd7
https://ibb.co/eH72d7

I would really appreciate it if someone could help me!
Advertisement
Site Helper
#2 Old 14th Feb 2018 at 6:05 PM
What does your resource.cfg file say?

I am Ghost. My husband is sidneydoj. I post, he downloads, and I wanted to keep my post count.
Group for Avatar Makers* Funny Stories *2017 Yearbook
Test Subject
Original Poster
#3 Old 14th Feb 2018 at 6:22 PM
Quote:
Originally Posted by Ghost sdoj
What does your resource.cfg file say?


It says:
Priority 501
DirectoryFiles Files/... autoupdate
Priority 1000
PackedFile Overrides/*.package
PackedFile Overrides/*/*.package
PackedFile Overrides/*/*/*.package
PackedFile Overrides/*/*/*/*.package
PackedFile Overrides/*/*/*/*/*.package
Priority 500
PackedFile Packages/*.package
PackedFile Packages/*/*.package
PackedFile Packages/*/*/*.package
PackedFile Packages/*/*/*/*.package
PackedFile Packages/*/*/*/*/*.package
Priority 499
PackedFile Test/*.package
PackedFile Test/*/*.package
PackedFile Test/*/*/*.package
PackedFile Test/*/*/*/*.package
PackedFile Test/*/*/*/*/*.package
Priority -50
PackedFile Probation/*.package
PackedFile Probation/*/*.package
PackedFile Probation/*/*/*.package
PackedFile Probation/*/*/*/*.package
PackedFile Probation/*/*/*/*/*.package
Priority 500
PackedFile DCCache/*.dbc
Alchemist
#4 Old 14th Feb 2018 at 6:46 PM Last edited by igazor : 14th Feb 2018 at 6:57 PM.
This may not be the direct cause of your issue with the test mods, but it will come back to haunt you later. Patch 1.62 is not a valid patch level. That one was included on the retail version of the ITF discs, but 1.63 was released just as the EP went to market. It also shows up among users of illegitimately obtained copies of the game that cannot be patched properly. When you get this bit worked out and if you attempt to use core or script mods, there will be problems because no mod developer ever worked to make their products compatible with that patch.

The "current" patch levels for TS3 are 1.67 and 1.69 (the latter including the dreaded Origin/Launcher tie-in).

May I ask what kind of installation this is and from where? If it's truly all retail store disc, there is an easy way to fix this.


Edit: I also have to ask if you are intending to have Windows display or hide extensions of file names. On one of your screenshots, they are hidden. On two of them, they are showing. If the true underlying name of the Resource file is Resource.cfg.cfg then this won't work. If the mod file is nointro.package.package that might be okay or it might not. It might be better to look at these folders all the same way, with extensions showing (not hidden like Windows seems to prefer).
Test Subject
Original Poster
#5 Old 14th Feb 2018 at 7:53 PM
Quote:
Originally Posted by igazor
This may not be the direct cause of your issue with the test mods, but it will come back to haunt you later. Patch 1.62 is not a valid patch level. That one was included on the retail version of the ITF discs, but 1.63 was released just as the EP went to market. It also shows up among users of illegitimately obtained copies of the game that cannot be patched properly. When you get this bit worked out and if you attempt to use core or script mods, there will be problems because no mod developer ever worked to make their products compatible with that patch.

The "current" patch levels for TS3 are 1.67 and 1.69 (the latter including the dreaded Origin/Launcher tie-in).

May I ask what kind of installation this is and from where? If it's truly all retail store disc, there is an easy way to fix this.


Edit: I also have to ask if you are intending to have Windows display or hide extensions of file names. On one of your screenshots, they are hidden. On two of them, they are showing. If the true underlying name of the Resource file is Resource.cfg.cfg then this won't work. If the mod file is nointro.package.package that might be okay or it might not. It might be better to look at these folders all the same way, with extensions showing (not hidden like Windows seems to prefer).


I'm so sorry I don't know why I put 1.62 on there (I will change it immediately) I think because I was reading a thread of someone saying they have that version and I thought I had that one too so I put it on here. I just checked to see which one I have because I was kind of confused as I have the real game. I have version 1.67 (not 1.69 or 1.62 sorry for the confusion) and there isn't a problem like the file being called Resource.cfg.cfg as I just checked.

I also tried other no intro mods (and other mods in general) that say they are compatible with my version but still nothing is working
Alchemist
#6 Old 14th Feb 2018 at 11:13 PM
Okay, we can rule out a couple of things there then and yes, 1.67 is a "real" patch and a much better one to be on.

I would suggest next pulling out or renaming your entire TS3 user game folder, thus forcing the game to spawn a new one with no content added on its next attempted launch. Set up the Framework again on the new game folder and see if it works any better.

If it does, then something is being stubbornly broken about the original one and it would be worth considering keeping the new, no content folder and begin populating it with your installed content, saves, etc. from the original one.

Another possibility is that you actually have a broken patch job and would have had no reason to suspect that until now. EA's SuperPatcher can fix that by forcing it to be reapplied, if you happened to have been using the Launcher to arrive at 1.67. It's a huge download but very easy to run once you've got it.
https://help.ea.com/en-us/help/the-...3-super-patcher
Test Subject
Original Poster
#7 Old 15th Feb 2018 at 9:31 PM Last edited by BDEmoTrash : 15th Feb 2018 at 9:44 PM.
Well, I think I found the problem if there's anyone out there with the same problem:

I could open and save my saves but there wasn't any saves document in the folder, this had me so confused because I didn't know how it was possible for there to be no save files and me still being able to play. This is when I remembered that when I installed The Sims 3 I had to go to my administrator account because I couldn't do certain things like update the game on my normal account. So I went to my administrator account and there I found another Electronic Arts file that does have my saves documents. I also have to start my TS3 game by giving my administrator password so this is why I thought that the documents might be on that account.

I am now going to try and put the mods in that Electronic Arts folder and update if it worked.

Edit: It worked!!!! After multiple days of sitting behind the computer and scanning all over the internet it finally worked! I hope this could maybe help someone in the future with the same problem <3
Back to top