Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 154 (Who?), Viewed: 6679 times.
Page 3 of 7
Not actually evil.
Original Poster
#51 Old 19th Jan 2018 at 11:56 PM
I noticed I have audio error logs. What is up with that? Saw some folks mentioning fixes for audio problems but can't remember where. Sound seems to work fine in my game but then why is it complaining about karaoke and DJ booth and event 'chair_liv_getup'???

[edit] My config log says it doesn't know my sound device. Is this a problem?

=== Sound device info ===
Name: Unknown
Driver: Unknown






@Justpetro - Your game works. Do you have these error logs in your Logs folder too? Is this normal?
@Jules1111 - same question as above
@gwynne - Do you recall seeing other folks mention audio errors?

Please spay or neuter your pets. --- Cat Music Video! --- my meshes
Not actually evil.
Original Poster
#52 Old 20th Jan 2018 at 12:13 AM
More stuff that didn't work, although it seems to have improved graphics performance a bit.
Not sure which one of these helped, I did both before testing.

* changed display resolution to have the same aspect ratio as my monitor, no need to stretch the display
* in NVidia Panel, settings for individual programs, turned off threading for Sims UC since the game only knows about one CPU
so should the GPU be spawning more threads? not sure if it's a problem but I turned it off

--------------------------------------

Question! Why does Kiri set the texture memory to 1744? How do we get that number? She knows graphics cards, I don't. I do know my card has 22504 mb of memory, more than 1744 mb, so should I be using that number instead? Kiri said something about Windows stuffing up the texture memory. Anyone know where that's explained? Leefish somewhere???

Please spay or neuter your pets. --- Cat Music Video! --- my meshes
Lab Assistant
#53 Old 20th Jan 2018 at 12:23 AM Last edited by Jules1111 : 20th Jan 2018 at 12:39 AM.
@CatOfEvilGenius Yes I have the Nvidia GTX1060 6gb. I am using the UC, not updated. I am using a NoCD version though, had to after removing Securom so it wouldn't reinstall. I am on Windows 10 home, version 1709.

I also have no sound devise found. So I don't think that is a big deal. error log from that is here



Have you tried to remove your video card and graphic rules files from the folders and just drop mine in? I have shared mine with several people when they were nervous about changing anything by hand, or might have had a mistake happen while doing it. So far everyone I shared with said their game works fine. You might want to give it a shot.

Edited to add I also use the 4gb patch.
Mad Poster
#54 Old 20th Jan 2018 at 6:39 AM
Good morning! Using Windows 10 home version 1709. (No Windows update has ever influenced my game negatively).

I use the updated UC from Origin - it runs perfectly through Origin but I prefer not to run it through Origin, so I use a noCD patch.

The problem in my opinion is not with Windows 10/ Origin/ UC, but somewhere else.

The tweaks you made (eg. no black box mod; graphic rules changes) are not going to stop the game for crashing, it will make the game look better! (I believe one needs to get the game running first and then do the tweaking).

(Just for information: Most programs have been updated to work with UC, and others can be made to work with UC. Clean Installer, in particular, works perfectly with UC).
Not actually evil.
Original Poster
#55 Old 20th Jan 2018 at 4:51 PM Last edited by CatOfEvilGenius : 20th Jan 2018 at 5:47 PM.
Haven't yet tried 4mb fix, will try that today...

I have tried several folks sgr and the one I modified myself, none work. Have been testing with no CC of any sort yesterday.

I checked. I have directx 12 and 11 and 10 and 9, all the dll's. I really hoped missing directx 9 dll's would be the problem but no. *bangs head on desk*

I now suspect maybe directx, although none of the errors say directx. I have directx 12. I suspect I don't have directx 9 because this machine is only months old and NOT cloned from an older one. Does Sims want directx 9, can I have both 9 and 12 (I think I can?), and how would I check if I do already have 9?

[edit] Just read that directx is supposed to be always backwards compatible and 12 should have all the stuff from 9. But will Sims 2 use it? Will it hurt anything to install directx 9? Has anyone done that and it helped???

[edit2] According to Microsoft, I should already have directx 9 if I have 12 and here are instructions for verifying that or reinstalling it if it's missing.
https://answers.microsoft.com/en-us...a5-3889aae764c1



@Justpetro - I suspected for a bit that the crashes were due to the game not recognizing the graphics card or having insufficient texture memory and running out, then crashing, but you may be right.

Anyone know how Kiri came up with the 1744 mb value for texture memory in her sgr and whether I can raise that safely? My card claims to have 22504 mb of texture memory.

Please spay or neuter your pets. --- Cat Music Video! --- my meshes
Lab Assistant
#56 Old 20th Jan 2018 at 9:47 PM
Quote:
Originally Posted by CatOfEvilGenius
Haven't yet tried 4mb fix, will try that today...

I have tried several folks sgr and the one I modified myself, none work. Have been testing with no CC of any sort yesterday.

I checked. I have directx 12 and 11 and 10 and 9, all the dll's. I really hoped missing directx 9 dll's would be the problem but no. *bangs head on desk*

I now suspect maybe directx, although none of the errors say directx. I have directx 12. I suspect I don't have directx 9 because this machine is only months old and NOT cloned from an older one. Does Sims want directx 9, can I have both 9 and 12 (I think I can?), and how would I check if I do already have 9?

[edit] Just read that directx is supposed to be always backwards compatible and 12 should have all the stuff from 9. But will Sims 2 use it? Will it hurt anything to install directx 9? Has anyone done that and it helped???

[edit2] According to Microsoft, I should already have directx 9 if I have 12 and here are instructions for verifying that or reinstalling it if it's missing.
https://answers.microsoft.com/en-us...a5-3889aae764c1



@Justpetro - I suspected for a bit that the crashes were due to the game not recognizing the graphics card or having insufficient texture memory and running out, then crashing, but you may be right.

Anyone know how Kiri came up with the 1744 mb value for texture memory in her sgr and whether I can raise that safely? My card claims to have 22504 mb of texture memory.


I believe that was the value she had on the card she has, or at least had at that time. I just used it as a base, but my game looks good and functions well with it so I never tweaked it. I really was afraid to put in the max my card would allow, I thought it might make the game explode since it is so old. I figured why mess with what is working? Yes you can tweak that higher if you wanted to. I know a lot of people that have it set higher then I do.
Not actually evil.
Original Poster
#57 Old 20th Jan 2018 at 10:00 PM Last edited by CatOfEvilGenius : 20th Jan 2018 at 11:33 PM.
Quote:
Originally Posted by Jules1111
I believe that was the value she had on the card she has, or at least had at that time. I just used it as a base, but my game looks good and functions well with it so I never tweaked it. I really was afraid to put in the max my card would allow, I thought it might make the game explode since it is so old. I figured why mess with what is working? Yes you can tweak that higher if you wanted to. I know a lot of people that have it set higher then I do.


I poked around on leefish and learned that you get that number from dxdiag. Look for dedicated graphics memory. Can also find it in nvidia panel, system info, dedicated graphics memory. Mine report slightly different values, 6052 from dxdiag and 6144 from nvidia, so I used the smaller. Didn't help. Still crashing. Then I tried the noCD exe again. Crashes EARLIER, on neighborhood load or during walking to a lot. The exe from Origin crashed while on a community lot.

I haven't done a clean install of graphics drivers yet but I looked at control panel, programs and features, and I seem to only have the latest nvidia drivers so do I need a clean reinstall??? I don't understand what kiri meant about Windows stuffing up texture memory. Did Windows bork the drivers? I guess I can do a driver reinstall and see what happens...

[edit] Did a clean install of drivers. Didn't help. Still crashing. *head desk, head desk, head desk*

Still haven't done the 4gb thing because it it's drivers, I want to rule that out first before giving the game more memory to play with. AAAAAAAAAAAAARGH. *rips out hair*

Please spay or neuter your pets. --- Cat Music Video! --- my meshes
Mad Poster
#58 Old 20th Jan 2018 at 10:10 PM
Cat - my game ran at once when I moved to Windows 10 (I used the UC on Windows 7 as well). The game was stuck in the 800 X 600 resolution. I only tweaked it then, it never crashed. (My game has actually only crashed twice in the past 3 years and both times it was due to hardware problems).

My card has 1744 mb as well - your card has more, so I can't see it running out of texture memory. Maybe the 4 GB patch will help (I don't know, my game ran without it for a long time, but it does make the game run a lot smoother). If you can change the resolution in the game and the game looks good, then your graphic fixes are done.

If you have lost any dll's, the game will not start at all ( a repair actually fixes that). So that is not the reason for crashing either, ever. I tend to think the same would apply for directx whatever.

Tip: Any lost or dropped drivers normally just need you to restart your pc with Windows 10 - no need to download them again. A restart puts them back.
Theorist
#59 Old 20th Jan 2018 at 10:39 PM
Quote:
Originally Posted by CatOfEvilGenius
I can play for a few sim game hours at most (not human real time hours). I play at double speed. This is my usual test routine. Enter the Caliente lot, send Nina to Commandgo in Downtown, have Nina buy two phones, then scope the room a few times and try to chat with people. I zoom out enough to see the entire lot. The game usually lets me buy two phones and crashes sometime during the scoping/chatting. I note that ms. Crumplebottom shows up sometimes, sometimes it's a vampire, but I don't think every crash happens with an NPC present. Sometimes it crashes before I get to the lot. Once it crashed in neighborhood while trying to open the main menu. So I can get into a sim's home lot, I can sometimes send them to a community lot, but they can't stay too long. Sometimes I try zooming in and putting the walls up to minimize what all has to be rendered, still crashes. Sometimes, not nearly as often, the game crashes on a sim's home lot for easily discernible reason. Once it was snowing heavily on a lot and it crashed earlier. Snow is resource intensive so maybe that's why.

[edit] Much more stable in sim home lots, could play longer, maybe half hour or longer sometimes in real time. Got more crashy if I had more visitors at the home lot so it looks like the game thinks it is low on computing/graphing resources even though I have modern hardware. This desktop is a few months old.
NVidia GeForce 1060 GTX 6mb and Intel i7-7700 dual core 3.6 GHz

Trying tweaked graphics rules, then going to try the 4gb thing next. Then going to look under couch pillows for money for a different graphics card, ha ha. I wish.


Just my two cents. Every newer version of Windows eats up more available RAM than the version before it, leaving less for this elderly game to use. Also, my game has always slowly increased the amount of RAM it uses while I'm playing (memory leak?). Please do try the 4gb patch. I'm using a disk-based game with Windows 7 and the 4gb patch made a huge difference in my game - it rarely crashes now (it crashed fairly often before the patch) and I can now use lots of big CC that I would never have dreamed of trying before (large hairs, SleepyTabby's default replacement skins, etc.).

Do you have Task Manager or Process Explorer or something similar in Windows 10 where you can see how much memory the game is using when you run it? Without the 4gb patch, my game usually used to crash when it got to about 1gb in memory - sometimes not even that big. Try to see how much memory the game is using when it crashes - that might tell you whether it's a RAM problem that could be fixed by the 4gb patch.
Mad Poster
#60 Old 20th Jan 2018 at 10:50 PM
Yes - you can use task manager. (I just type task manager in the search box). I am definitely for the 4 GB patch.
Not actually evil.
Original Poster
#61 Old 20th Jan 2018 at 11:43 PM Last edited by CatOfEvilGenius : 21st Jan 2018 at 12:05 AM.
Quote:
Originally Posted by Justpetro
Yes - you can use task manager. (I just type task manager in the search box). I am definitely for the 4 GB patch.


I didn't know I could do that with task manager, thank you. Looked at task manager, it says Sims was using 333mb when it crashed. Not even 1 gb. I will try th 4gb patch next, nothing else has worked and I think I have now literally tried everything I could find on leefish and here.

For some reason, task manager is now showing me CPU usage. It never, ever did that before, just listed processes running that I could kill. I didn't turn that on, as far as I know. Weird.

[edit] Do I need the data execution prevention thing too? I'm a computer scientist, I know only instructions should be executed, not data, and something is seriously wrong if data is being executed, but does DEP work on Windows 10 and is it needed? Sorry if someone already told me, eyes glazing over from testing damn crashy game.
old GoS thread discussing 4gb patch and DEP

Please spay or neuter your pets. --- Cat Music Video! --- my meshes
Not actually evil.
Original Poster
#62 Old 21st Jan 2018 at 12:26 AM Last edited by CatOfEvilGenius : 21st Jan 2018 at 2:20 AM.
So I now have four versions of the exe.

1) Origin version, crashy
2) noCD version, crashy, even more than Origin version
3) noCD version patched to use 4gb by CFF, loads neighborhood that flashes pink, what the...
4) Origin version patched to use 4gb, haven't tested this one yet, scared to. Also hungry, need dinner. Will be out of options once I test that. It will probably crash. *cries*

[edit] The Origin executable, when patched to use 4gb, will not even run. It makes Origin start up, but Sims doesn't start.

[edit2] Only the noCD exe flashes pink. The Origin one does not. Origin crashes usually when on a community lot.
side note: I have 32 gb of RAM. If the game is running out of memory, how on earth does it manage that? Windows bloat eating all the memory???


Please spay or neuter your pets. --- Cat Music Video! --- my meshes
Field Researcher
#63 Old 21st Jan 2018 at 1:46 AM
Flashing pink, nor not launching the game has NOTHING to do with 4GB patch. It does not do anything else than lets the game use more memory. So the problem still is at somewhere else. You did use the exe at post #60, right?

And agreeing with @Justpetro, did you make all the testing after or before you tweaked the TM-trademark out? test first then tune. I am not even sure is the UC going to actually work with not the TM. and SimPE and cleaninstaller and many others DO work just fine with original UC.

Edit: at the pink flashin hood, did you try did Brandi managed to get the food?

~~~~Call me Ellu ~~~

Past the point of no return,
No going back now,
Our passionplay is now begun.
Past thought of right or wrong, final question, how long have we wait before we're one?
~Andrew Loyd Webber (Phantom Of The Opera)

If curious, my Widespot+LGU+Bigg City
Not actually evil.
Original Poster
#64 Old 21st Jan 2018 at 2:26 AM Last edited by CatOfEvilGenius : 21st Jan 2018 at 2:53 AM.
Quote:
Originally Posted by Kukamuukaanmuka
Flashing pink, nor not launching the game has NOTHING to do with 4GB patch. It does not do anything else than lets the game use more memory. So the problem still is at somewhere else. You did use the exe at post #60, right?

And agreeing with @Justpetro, did you make all the testing after or before you tweaked the TM-trademark out? test first then tune. I am not even sure is the UC going to actually work with not the TM. and SimPE and cleaninstaller and many others DO work just fine with original UC.

Edit: at the pink flashin hood, did you try did Brandi managed to get the food?


Kukamuukaanmuka - Without the 4gb patch, the noCD exe does not even load the neighborhood. I'll check to see if it's the same as the one in post #60. UC from Origin does work with no TM as well as with the TM for me, in other words, crashes the same way with or without the TM. I can try to do Origin repair, that resets all the registry keys, try playing with the TM again, for science. I did not open any lots in the pink flashing hood, was too horrified by the pink flashies. I can try that in a bit... Thank you for popping in to help. You all keep me from not giving up. Once more into the breach!

[edit]
@Kukamuukaanmuka - Erm, not sure which exe is the one from post 60. I looked at post 60. Followed the link in post 60, took me to another thread with another link at the top, that link was broken. Are we talking about an exe that we can't discuss on MTS? The pink flashy is from a noCD one that I can't link to on MTS.

-------------------------------------

Ok, starting over again. Please note this round of testing is after doing a clean install of nvidia drivers.

* Origin - did a repair, using Origin exe
* [edit] and I removed the entire EA Games/Sims 2 folder from Documents so the game would regenerate it
* using origin sgr files
* only thing I changed was the shortcut, -w -CPUCount:1 and XP sp2 compatibility and administrator

let's see what happens...

Please spay or neuter your pets. --- Cat Music Video! --- my meshes
Field Researcher
#65 Old 21st Jan 2018 at 3:31 AM Last edited by Kukamuukaanmuka : 21st Jan 2018 at 3:40 AM. Reason: why I cannot learn to type :(
I apologize of my tence of my post, has been a rough day and I am not speaking english at my native language

so , 4GB patch, what *EDIT to note*= I used is this: http://www.ntcore.com/4gb_patch.php

Edit 2: still out of curiosity, the pink flashing.. did Brandi got the groceries? I mean if she did then we are talking again about graphics.

~~~~Call me Ellu ~~~

Past the point of no return,
No going back now,
Our passionplay is now begun.
Past thought of right or wrong, final question, how long have we wait before we're one?
~Andrew Loyd Webber (Phantom Of The Opera)

If curious, my Widespot+LGU+Bigg City
Theorist
#66 Old 21st Jan 2018 at 3:57 AM
Quote:
Originally Posted by CatOfEvilGenius
I didn't know I could do that with task manager, thank you. Looked at task manager, it says Sims was using 333mb when it crashed. Not even 1 gb. I will try th 4gb patch next, nothing else has worked and I think I have now literally tried everything I could find on leefish and here.

For some reason, task manager is now showing me CPU usage. It never, ever did that before, just listed processes running that I could kill. I didn't turn that on, as far as I know. Weird.


Perhaps you're used to looking at one of the other tabs. "Applications" only shows a list of running programs you can kill. "Processes" normally (in Win 7 anyway) shows name of process, name of user running it, CPU usage, RAM used, and a brief description of the process.

Quote:
Originally Posted by CatOfEvilGenius
[edit] Do I need the data execution prevention thing too? I'm a computer scientist, I know only instructions should be executed, not data, and something is seriously wrong if data is being executed, but does DEP work on Windows 10 and is it needed? Sorry if someone already told me, eyes glazing over from testing damn crashy game.
old GoS thread discussing 4gb patch and DEP


I have a very vague memory of going through all that stuff when I first set up this computer and installed TS2 on it (which wasn't really very long ago). It might have been that thread you linked to - feels familiar. On my Win 7 machine, I have DEP turned on "for all programs and service except those I select". Sims 2 is checked as an exception. I have apparently been running my machine and game this way for about a year now and don't seem to have any problems from these settings.

Flashing pink like in your screenshot usually indicates that your game is out of texture memory. 32Gb of system RAM will not affect this one way or the other - this kind of thing is handled by the memory on your graphics card. Strange that yours is doing this immediately on starting the game and loading a neighborhood.

Here is a video that offers several possible solutions for pink flashing, but usually this only seems to happen after playing the game for awhile.

https://www.youtube.com/watch?v=qLkmxAg7r3Y

Here are some suggestions from the video that I thought might help. Reboot your computer if it's been awhile since you last did that. Remove high-poly, high-detail CC such as high-poly hairs, etc. Try turning all your TS2 graphic options down. The video also suggests turning shaders off. Start with these minimal settings and if that seems to work, you can turn them back up a little at a time.

I hope some of this is useful to you. All this must be driving you nuts.
Not actually evil.
Original Poster
#67 Old 21st Jan 2018 at 5:04 AM Last edited by CatOfEvilGenius : 21st Jan 2018 at 5:22 AM.
Quote:
Originally Posted by RoxEllen1965
<snip> The video also suggests turning shaders off. Start with these minimal settings and if that seems to work, you can turn them back up a little at a time.

I hope some of this is useful to you. All this must be driving you nuts.
Thank you. I did edit my sgr file to turn shaders on when I tested and got the pink flashies. I'm currently testing with UC from Origin, the Origin sgr files with no alterations, 800x600 resolution, no CC at all, totally removed the Sims Documents folder so the game would regenerate it. Only thing I changed is -w -CPUCount:1 on the shortcut, admin mode, and XP sp2 compatibility.

I DID do something with shaders maybe in NVidia panel, let me go double check that.

Ku - Your English is great, no worries. Yes, I was using the 4gb tool from the link you just posted. That's what I used on the noCD exe and then got pink flashies. Am currently testing the Origin exe with Origin's sgr files, no cc, tiny 800x600 resolution, fresh Documents folder, no changes to anything by me except the shortcut, -w -CPUCount:1. Like you and Justpetro said, or mabye Jules, get it working unaltered first, then change stuff. So true. Someone said that. Can't remember. Need more sleep.

------------------------------------------------------------------

[edit] Unaltered Origin UC exe with Origin's sgr files CRASHES when sending Nina Caliente to Commando. I did NOT mess with registry to remove the TM symbol, playing with the TM symbol in the Doc file name. Has the 32mb texture memory problem, see snippet of config log file below.

=== Graphics device info ===
Number: 0
Name (driver): NVIDIA GeForce GTX 1060 6GB
Name (database): NVIDIA GeForce GTX 1060 6GB <<NOT FOUND IN DATABASE!>>
Vendor: NVIDIA
Chipset: Vendor: 10de, Device: 1c03, Board: 62673842, Chipset: 00a1
Driver: nvldumd.dll, Version: 23.21.13.9065, GUID: D7B71E3E-5F43-11CF-9B78-6A421BC2DA35
Driver version: 9065
Monitor: \\.\DISPLAY1
Monitor aspect: 1.776119, 16:9
Screen mode: 1600x900x32BPP,60Hz
Texture memory: 32MB

Now let's try sending Brandi Broke grocery shopping, same setup. I'm guessing it will crash too because teeny tiny 32mb texture memory. Still UC from Origin, 800x600, no changes except -w -CPUCount:1 on shortcut, admin, XPsp2 compatibility... and I did NOT mess with registry to remove the TM symbol, playing with the TM symbol in the Doc file name.

After that, I'll try Brandi/groceries and Nina/Commandgo again but with my sgr files. Or I will go sleep and bang my head on this wall tomorrow. One of those.

Please spay or neuter your pets. --- Cat Music Video! --- my meshes
Theorist
#68 Old 21st Jan 2018 at 6:11 AM Last edited by RoxEllen1965 : 21st Jan 2018 at 6:26 AM.
That tumblr that was linked to earlier has instructions near the end of it on what to do to your Graphics Rules.sgr file if your config log says you only have 32MB of memory.

http://simlili.tumblr.com/post/146373494212

Get some food and sleep first. Maybe spend some time doing something fun to relax for awhile before attacking this again. Here's hoping you get it this time!
Mad Poster
#69 Old 21st Jan 2018 at 6:24 AM
Flashing pink - try deleting the thumbnails. See here: http://www.leefish.nl/mybb/showthread.php?tid=7705 for more solutions. (Deleting the thumbnails works for me, only happened two or three times in my game). Holding thumbs! Apologies for replying "late" but is just past 7 in the morning here

I don't have DEP turned on.
Not actually evil.
Original Poster
#70 Old 21st Jan 2018 at 4:57 PM Last edited by CatOfEvilGenius : 21st Jan 2018 at 7:52 PM.
Quote:
Originally Posted by RoxEllen1965
That tumblr that was linked to earlier has instructions near the end of it on what to do to your Graphics Rules.sgr file if your config log says you only have 32MB of memory.

http://simlili.tumblr.com/post/146373494212

Get some food and sleep first. Maybe spend some time doing something fun to relax for awhile before attacking this again. Here's hoping you get it this time!


Food and sleep gotten, yay! I do have sgr files that fix the 32mb bug and set the texture memory to 6052 which is what my dxdiag reports. Nvidia panel says 6144 for some reason, which one's 'right'? I was using those earlier, tried a ton of things, but nothing I did helped. I'm starting from scratch again, adding one tiny change at a time. On the list today...

* add my modified sgr files back in to fix the 32mb issue (won't fix crashes, I know from many previous attempts)
* [edit] Do another clean install of nvidia drivers , this time using Guru3D DDU and then manually installing drivers because GeForce is crashy and Kiri and others recommend doing this manually
* [edit2] I may also try using an older driver reported by some to be stable like 355 or 362 rather than 390.65 (current) because I keep crashing with 390.65 and others report problems with it
* try using nvidia panel to adjust program settings for sims, go from smooth and lovely to ugly and jaggedy but less taxing, see if that gets rid of crashes (try both Origin and noCD executables)
* try changing in game video settings to medium (bleh, yuck) and see if that fixes crashes, I refuse to play if I can't have high settings, but it's data
* try deleting thumbnails per suggestion above to fix 'pink flashies' in neighborhood, only happens with noCD exe, not with the Origin one

Justpetro - No worries, I don't expect folks to reply quickly, we all have lives outside of Sims.

-------------------------------------

[edit] NVidia peeps! Install your drivers as in this video , not with GeForce experience. Kiri from leefish recommends that video and GeForce experience crashed for me when installing drivers. She says Windows mucks up NVidia drivers and texture memory.

Who here has an NVidia card, please remind me, did you use that video? Did you have to do a clean install of drivers?

Please spay or neuter your pets. --- Cat Music Video! --- my meshes
Not actually evil.
Original Poster
#71 Old 21st Jan 2018 at 8:41 PM Last edited by CatOfEvilGenius : 21st Jan 2018 at 10:46 PM.
Crashed but took longer to crash, I think? Progress maaaaaaaybe?

* I did a manual CLEAN INSTALL of the NVidia drivers using DDU to uninstall drivers in Safe Mode, then installed NVidia driver 390.65 (current one) manually, NOT using GeForceExperience.
I also turned off Windows driver auto update and when reinstalling NVidia drivers, just did not install awful crashy GeForce Experience. If the 390.65 driver won't work, I will rinse and repeat
this procedure with an earlier driver. Wasn't able to get 355.60 nor 362, the nvidia site no longer has them, so I'll just try the next earliest version and/or the earliest one I can get.
I have not done a correct clean install before. I used GeForce Experience which is not recommended by Kiri nor other gamers who made videos about NVidia drivers borking games.

* I am using Origin sgr files right now so I know I have the 32mb issue (I know how to fix it, have my own sgr files I'll try next)
I am in 800x600 mode because Origin sgr files (so teeny!)

* I am running the Origin exe, vanilla game, no CC, not even CEP, and have not removed the TM from the Doc folder, as vanilla as can be

next step: put in my sgr files (Kiri's nvidia texture memory fix with my own value for texture memory, 6052 mb, that I got from dxdiag)
will report...

----------------

[edit2] - Crashed, but took MUCH LONGER before crashing! Progress!!! Yay? I was almost ready to celebrate, then crash.
Before, I would send Nina to Commandgo during the day and in the evening, about after it got dark, the game would crash. This time, she stayed at Commandgo almost until the next morning, much longer before crashing than any of the previous three days tests! I'm trying to be optimistic.

* did CLEAN INSTALL of nvidia drivers using DDU and manual driver install, per video linked above,
playing with driver version 390.65 for NVidia GeForce GTX 1060 6mb
* Origin UC exe, [edit] compatibility for Win XP sp2, windowed, -CPCount:1, run as admin
* my sgr files (Kiri's nvidia texture memory fix with my 6052 mb value I got from dxdiag)
* still using 800x600 resolution
* vanilla game in every other way, no CC, not even CEP, and did not mess with the registry to remove TM

Next steps: remove cache files, repeat this test on Brandi and grocery shopping, then maybe try an older driver and see if its more stable???
Maybe turn down graphics quality in game and/or in nvidia panel and see if that helps with stability.

---------------

I think Chumbalumba's "Tubthumping" should be my soundtrack to trying to get this game to work. I get knocked down but I get up again!

@gwynne - When you did a clean install of the nvidia driviers, did you use GeForce Experience or install the drivers manually? And how did you uninstall the previous drivers beforehand? Windows built in tools or DDU? I religiously followed the instructions in the video Kiri linked to this time. We'll see if it helps.

Please spay or neuter your pets. --- Cat Music Video! --- my meshes
Mad Poster
#72 Old 21st Jan 2018 at 9:31 PM
Back when I went from Windows 7 to Windows 10, I did not change computers, since I had a brand new one, so most of the installing was done by Windows 10 - I do update my Nvidia with G-Force updates, though. I honestly can't remember if I had to install any Nvidia drivers myself.
Lab Assistant
#73 Old 21st Jan 2018 at 10:17 PM
I have a Nvidia card. I have always updated the drivers through Geforce experience. I know I read that it was better to do it yourself, but I figured if it was working I would worry about that when it stopped working. Can I ask why you put -CPUCount:1 in? I have never altered how many cores, and I have never launched in compatibility mode either. The only alterations to the game I have ever made were the graphic rules and video card files.

I also had a pink neighborhood with my GTX960, but that issue resolved itself after altering the graphic rules and video card files. Mine was a bit different though. A darker purple, and it was more like a fog over the whole neighborhood. I do hope you can get your game running. I have never seen someone have so many issues. I wish I could be more help, but these issues go beyond what I have ever experienced.
Not actually evil.
Original Poster
#74 Old 21st Jan 2018 at 10:44 PM Last edited by CatOfEvilGenius : 22nd Jan 2018 at 12:15 AM.
Quote:
Originally Posted by Jules1111
I have a Nvidia card. I have always updated the drivers through Geforce experience. I know I read that it was better to do it yourself, but I figured if it was working I would worry about that when it stopped working. Can I ask why you put -CPUCount:1 in? I have never altered how many cores, and I have never launched in compatibility mode either. The only alterations to the game I have ever made were the graphic rules and video card files.

I also had a pink neighborhood with my GTX960, but that issue resolved itself after altering the graphic rules and video card files. Mine was a bit different though. A darker purple, and it was more like a fog over the whole neighborhood. I do hope you can get your game running. I have never seen someone have so many issues. I wish I could be more help, but these issues go beyond what I have ever experienced.


I've always used GeForce Experience up until now. Did notice a very significant difference when I installed myself. I've been reading that the newest nvidia drivers install and work fine for some people and really muck things up for others. Lots of videos on youtube about nvidia drivers breaking games, modern ones, old ones, and people fixing it by reinstalling drivers manually. I didn't even know about it until trying to run Sims UC because it never affected me before.

I'm doing one core because I read on leefish and I think here that it might help. Origin or Windows or something may try to run threads on mutliple cores and Sims was never meant to run that way. Some people report they get lag or speed up/slow down that goes away when they add -CPUCount:1. I just get crashes, haven't noticed slowness, but thought it can't hurt to add that. I can remove it for science but I didn't notice a difference before, with or without -CPUCount:1.

gwynne is having similar issues, has a thread on leefish about them. She's in IT and is testing Sims UC on multiple machines with different versions of Windows 10 and different nvidia drivers. I'm very curious what her tests will turn up. So far, lots and lots of crashes, like me.

@Jules1111 - found the link that discussed one core, or one of the links anyway
http://www.leefish.nl/mybb/showthread.php?tid=6901

------------------------------------

[edit] Brandi crashes in Bluewater Here or Else Grocery. Same settings as previous test.

* Windows update version 1709
* NVidia 1060 GTX 6mb - driver version 390.65 clean installed myself using DDU and manual driver install
* Origin executable, -w -CPUCount:1, run as admin, compatibility for XP sp2
* no CC whatsoever
* 800x600 resolution (windowed)
* custom graphics rules / video cards sgr with 6052 mb instead of 32 mb for texture memory (nvidia fix, number from my dxdiag)

------------------------

as test above, but used noCD 4gb exe instead of Origin exe
got worse performance than Origin
was able to enter Caliente lot, send Nina to Commandgo, but once there, objects in the community lot flashed pink
will try to delete all files in Thumbnails, then try noCD again, but not optimistic, it keeps being worse than the Origin exe

--------------------------

as noCD test above
deleted cache files, everything in Thumbnails, tried noCD 4gb exe again
no pink flashies, got Nina to Commandgo, crashed before she could even buy one phone
again, much worse than Origin exe (both crash, but Origin takes much, much longer to crash and never had pink flashies)

Please spay or neuter your pets. --- Cat Music Video! --- my meshes
Lab Assistant
#75 Old 22nd Jan 2018 at 1:36 AM
@CatOfEvilGenious Interesting thread. I have never had any lag, I suppose I just got lucky since apparently some people have. This is the third pc I have installed the game on, and it has been nothing but quick fixes to the files each time. It is really odd that you crash faster with the noCD version. I honestly wouldn't have expected that to make a difference.
Page 3 of 7
Back to top