Replies: 2 (Who?), Viewed: 7987 times.
Original Poster
#1 Old 29th Dec 2018 at 7:25 AM
Default Secret vacation lot
Hi...I am creating a custom vacation hood. It is pretty much finished, and being tested...but the secret lot is not producing Bigfoot.

The lot has been successfully hidden in the hood, and appears in the destination menu when a sim has found the map, but no Bigfoot is there when visited.
This is even odder because in an earlier iteration of the lot, I did have Bigfoot appearing and interacting with my sims. The lot should not have changed much, if at all, since then, although it has been renamed.

The only hint I have found is a suggestion by maxon that the lot must be named exactly like the EA version. However, my lot has never been so named, and used to work. The name is currently AE-HiddenBurrow. Is it possible that the hyphen is preventing Bigfoot? Seems unlikely.

I also found a thread on MTS at one stage which showed that it was possible to have (and visit) more than one secret lot in the same hood, with the default NPC appearing in whichever one you visited. I can't find that thread any more, but those lots can't have had identical names.

Anyone able to advise?
#2 Old 30th Dec 2018 at 1:56 AM
The only two requirements for the Bigfoot Controller to spawn a bigfoot is the correct neighbourhood type and correct lot zoning. If they are correct then the Bigfoot Controller is 'locked in a loop', if the controller runs for 5 ticks when the lot zoning is incorrect it'll go into a never ending idle loop. If the lot was saved after the controller had run then that is most likely what has happened, since all controllers run a little on loading it not inconceivable that it did make the 5 ticks by itself.

You need to somehow delete the Bigfoot Controller from the lot so a fresh one will be generated, which is a little extra difficult in secret holiday lot because you have to change the lot zoning before you can make and save any changes.

If there is no other way then will fix it.
"This item will delete all controllers, off world items and any NPC schedules. It deletes everything on initialization so just select then delete it, the lot does not need to go into live mode for it to work. This ensures the lot runs a fresh set of controllers next time the lot loads.
Find in general / miscellaneous category of the catalogue"

I recommend removing it from your downloads folder when it's not needed to prevent accidental use.
Original Poster
#3 Old 30th Dec 2018 at 2:43 AM Last edited by aelflaed : 30th Dec 2018 at 5:40 AM.
Maybe that is the problem. The only other inconsistency I can find is that the LOTD does not match the catalog name of the lot - still has the hyphen. I can't see how to edit that.

I am quite good at changing the lot zoning and hidden-ness on that lot by now, actually.

Sounds like Pescado's batbox might do the trick, but would have to be in live mode - so, change back to a comm lot, send a sim along, use batbox and cross fingers? Or try yours...if I understand correctly, using the loadlot cheat should be enough - load the lot, place the LotCleaner and delete it again. Have I got that right?

I will give it a go.

EDIT: so that IS the problem, but I still have to figure out how to fix the template. My test sims were able to visit the lot and use the batbox to delete the stuck controller, and Bigfoot appeared almost instantly. However, I had already used loadlot to place and then delete your object in the template hood, which did NOT produce Bigfoot, so I must need to do something extra there. My building version has no sims, so nothing can be done in live mode. Do I need to be able to save the lot after using the LotCleaner? Have to switch back to a comm lot, in that case.

EDIT: I think it is all fixed now. Process for later searchers...
-in SimPE - unhide your secret lot and flag it as a community lot.
-in game - load your lot, grab CJH LotCleaner from catalog, wait a moment (it's doing its thing, just hold on). Delete Cleaner. Save lot. Exit.
-in SimPE - flag as secret vacation lot and re-hide.
-in game - check. Bigfoot should now appear as normal.

Thanks for identifying the problem, Chris, and providing a solution!
Back to top